Move postgresql support into a separate plugin